RSS feed
Nieuws
Jun
13
Oude versies van PHP (lager dan 5.6) en mod_php / Apache PHP.
Geplaatst door Michel [Support] aan 13-06-2018 21:15

Het is ons opgevallen dat er in anno 2018 altijd nog een groot deel van de Plesk klanten zijn of haar websites draaien met extreem oude versie van PHP!

De onderstaande PHP versies binnen Plesk zijn gewoon te oud om te gebruiken en zeer onveilig:

  • PHP 5.2 - laatste update in januari 2011 (+/- 7 jaar geleden)
  • PHP 5.3 - laatste update in augustus 2014 (+/- 4 jaar geleden)
  • PHP 5.4 - laatste update in september 2015 (+/- 3 jaar geleden)
  • PHP 5.5 - laatste update in juli 2016 (+/- 2 jaar geleden)

Al deze versies zijn inmiddels EOL, wat betekend End-Of-Life. Er komen voor deze versies geen (beveiligings)updates meer uit!

Te oude PHP-versie en fout gebruik!

Wanneer u een dergelijke oude versie van PHP draait is de kans aannemelijk dat uw website gehackt of misbruikt kan worden door derden.
Het is derhalve te adviseren, als Plesk gebruiker, om zo spoedig mogelijk uw PHP-versie binnen Plesk aan te passen.

Moderne websites, zoals Wordpress, Joomla en Drupal ondersteunen gewoon de modernere versies van PHP (denk hierbij dus aan PHP 7.x).
Wij adviseren om uw PHP-instellingen (binnen Plesk) minimaal aan te passen naar PHP 5.6 en deze uit te voeren als zijnde FastCGI.

Hogere versies van PHP betekenen niet alleen meer veiligheid, maar ook 98% van alle gevallen een veel snellere en soepelere website!
Dat is zeker het geval met PHP-versies, zoals: 7.0, 7.1 en 7.2.

Wanneer u klant bent met een Plesk of Plesk Onyx interface, dan kunt u heel éénvoudig van PHP-versie wisselen (binnen enkele seconden).


Het stappenplan om uw PHP-versie binnen enkele seconden aan te passen binnen Plesk (Onyx):

  1. Log als eerste in op uw Plesk omgeving via https://uwdomeinnaam.nl:8443 of via http://uwdomeinnaam.nl:8880 *
  2. Eénmaal ingelogd in Plesk, klikt u op "PHP Settings" of "PHP-instellingen"
  3. Nu klikt op de PHP versie en selecteert (minimaal) PHP 5.6.x of een hogere versie
  4. Indien "run PHP as" of "PHP uitvoeren als" niet aangepast wordt naar "FastCGI", dan zelf deze selecteren
  5. Nu omlaag scrollen en op "OK" klikken

U heeft nu, binnen enkele seconden, de PHP versie waar uw website op draait aangepast.

Het is nu zaak om te controleren of uw website zonder problemen draait. Normaal gesproken, zeker bij moderne en goed onderhouden websites zoals Wordpress, Joomla en Drupal, zal dit niet tot problemen leiden.
Indien er wel problemen ontstaan kijk dan eerst in de log-bestanden (eveneens binnen de Plesk interface) of er een duidelijk foutmelding staat. Lukt het niet, probeer dan een andere PHP-versie.

Mochten er problemen blijven met de website, hetgéén wat kan gebeuren met (extreem) oude en/of niet onderhouden websites, dan zou een iets lagere versie van PHP kunnen proberen.
Maar vermijd sowieso het gebruik van mod_php (ook wel Apache PHP genoemd). Dit zorgt er niet alleen voor dat uw website een stuk onveiliger is, maar is ook het grootste probleem inzake verkeerde bestands- en/of maprechten.

Wanneer u toch een oudere versie van PHP gebruikt (en u wel mod_php vermijd te gebruiken), dan is het raadzaam om eens contact op te nemem met de websitebouwer om de website aan te passen of een compleet nieuwe website te bouwen.
Bijvoorbeeld een Wordpress website of (onze) Websitebuilder. Beide zijn te gebruiken voor beginnende alsook doorgewinterde website bouwers / hobbyisten.

Tot slot nog een laatste opmerking; wij blijven voorlopig de oude PHP-versies op een aantal servers ondersteunen, maar de kans bestaat / is aannemelijk dat deze op korte termijn compleet van onze servers verwijderd worden. Dit uit oogpunt van de veiligheid van de andere klanten, de server en uiteraard uzelf.

 

* Mocht u een melding zoals "Uw verbinding is niet beveiligd" krijgen ofzoiets dergelijks, dan is er niks aan de hand. Dit komt doordat uw website nog geen SSL certificaat heeft geinstalleerd en het standaard certificaat gebruikt van de (Plesk) server. U kan dan klikken op geavanceerd en vervolgens een uitzondering toevoegen. Vervolgens kunt u dan gewoon inloggen.

 


Reacties (0)
Help Desk Software